re = /^([0-9]{0,2}|5[0-9])$/m
str = '<--! select 0 or 00..59 sequences -->
0
1
9
00
09
10
33
45
55
59
99
000
001
002
004
010
011
021
100
101
110
115
120
125
127
135
139
141
201
222
230
245
247
250
254 sgnlfsf
2340
345
255
853
999'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end