import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<timestamp>\\d{4}-\\d{2}-\\d{2} \\d{2}:\\d{2}:\\d{2},\\d{3}) (?P<level>INFO|ERROR|WARN|TRACE|DEBUG|FATAL)\\s+\\[(?P<firstSquareBrackets>[^\\]]*)]\\s+\\[(?P<secondSquareBrackets>[^\\]]*)]\\s+\\[(?P<thirdSquareBrackets>[^\\]]*)]\\s+\\[(?P<fourthSquareBrackets>[^\\]]*)]\\s+\\[(?P<fifthSquareBrackets>[^\\]]*)] - (?P<textMessage>.*?)(?=\\\\Z|;\\s+|\\n)|(?P<exception>^.+Exception: .+)|(?P<stacktrace>^\\s+at .+)|(^\\s+... \\d+ more)|(^\\s*Caused by:.+)";
final String string = "2018-07-24 00:01:33,711 WARN [r3223r2r3] [] [] [ewqrwerwer] [ewfwefwef] - Failed;\n"
+ "2018-07-24 00:01:33,712 DEBUG [r3223r2r3] [] [] [ewqrwerwer] [ewfwefwef] - Sample log\n"
+ "2018-07-24 00:02:33,712 DEBUG [r3223r2r3] [] [] [ewqrwerwer] [ewfwefwef] - Sample log\n"
+ "2018-07-24 00:20:33,830 DEBUG [r3223r2r3] [] [] [ewqrwerwer] [ewfwefwef] - Sample log\n"
+ "2018-07-24 00:20:37,731 DEBUG [r3223r2r3] [] [] [3r2r32r] [c.i.s.h.r.i.RssNewsServiceImpl] - 3r232r\n"
+ "2018-07-24 10:33:45,852 ERROR [r3223r2r3] [fgd] [gr] [reger] [regre] - Sample log\n"
+ "javax.servlet.ServletException: Something bad happened\n"
+ " at com.example.myproject.OpenSessionInViewFilter.doFilter(OpenSessionInViewFilter.java:60)\n"
+ " at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1157)\n"
+ " at com.example.myproject.ExceptionHandlerFilter.doFilter(ExceptionHandlerFilter.java:28)\n"
+ " at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1157)\n"
+ " at com.example.myproject.OutputBufferFilter.doFilter(OutputBufferFilter.java:33)\n"
+ " at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1157)\n"
+ " at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:388)\n"
+ " at org.mortbay.jetty.security.SecurityHandler.handle(SecurityHandler.java:216)\n"
+ " at org.mortbay.jetty.servlet.SessionHandler.handle(SessionHandler.java:182)\n"
+ " at org.mortbay.jetty.handler.ContextHandler.handle(ContextHandler.java:765)\n"
+ " at org.mortbay.jetty.webapp.WebAppContext.handle(WebAppContext.java:418)\n"
+ " at org.mortbay.jetty.handler.HandlerWrapper.handle(HandlerWrapper.java:152)\n"
+ " at org.mortbay.jetty.Server.handle(Server.java:326)\n"
+ " at org.mortbay.jetty.HttpConnection.handleRequest(HttpConnection.java:542)\n"
+ " at org.mortbay.jetty.HttpConnection$RequestHandler.content(HttpConnection.java:943)\n"
+ " at org.mortbay.jetty.HttpParser.parseNext(HttpParser.java:756)\n"
+ " at org.mortbay.jetty.HttpParser.parseAvailable(HttpParser.java:218)\n"
+ " at org.mortbay.jetty.HttpConnection.handle(HttpConnection.java:404)\n"
+ " at org.mortbay.jetty.bio.SocketConnector$Connection.run(SocketConnector.java:228)\n"
+ " at org.mortbay.thread.QueuedThreadPool$PoolThread.run(QueuedThreadPool.java:582)\n"
+ "Caused by: com.example.myproject.MyProjectServletException\n"
+ " at com.example.myproject.MyServlet.doPost(MyServlet.java:169)\n"
+ " at javax.servlet.http.HttpServlet.service(HttpServlet.java:727)\n"
+ " at javax.servlet.http.HttpServlet.service(HttpServlet.java:820)\n"
+ " at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:511)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}