using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d+\s+-[^-]*";
string input = @"""Opcao 01 - Frase aleatória - Menu Superior"",
""Opcao 02 - Outra Frase aleatória - Menu Su"",
""Opcao 03 - Mais 01 Frase - Menu"",
""Opcao 04 - Mais Frase -"",
""Opcao 05 - Frase Simples"",";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}