$re = '/(.*?;){10}(.*?);/';
$str = 'TPD;62384;P;;;;N;62308;N;;C;N;N;;F;02';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);