package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[\W_]+`)
var str = `(+Some_123.]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}