re = /{{[^{}]*}}/
str = '{{number}}-{{$index}}
{{number}} all kinds of things are here 190378ckkvmnlfadg@#$@#$@#!%$@$%!~W { §É4ΦX2░☻â&4♫♫Y╧╬ including another {{! {{$index}}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end