$re = '/The/';
$str = 'The fat cat sat on the mat.
the fat cat sat on the mat.
THE fat cat sat on the mat.
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);