$re = '/^((?!\/api\/).)*$/m';
$str = 'http://test.test/Webseite/api/date/blabla';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);