import re
regex = re.compile(r"^(\p{Han}+)(?:\P{Han}.*\1)?$", flags=re.MULTILINE)
test_str = ("测试1003##$%#测试\n"
"测试1003##$%#测\n"
"测试")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")