re = /:([^:\/]*)/
str = '/resource/:paramName/another-resource/:anotherParam/final-resource/:as'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end