# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^r(?:100|[1-9]\d|\d)---sn-vgqs(?:rne(?:s|z)|kne(?:s|z)|knlz|kn7e|7ney|kne6|kn76|7ns7|ener|kn7z|knek|7nly)\.googlevideo\.com$"
test_str = ("r4---sn-vgqsrnez.googlevideo.com\n"
"r1---sn-vgqsknlz.googlevideo.com\n"
"r5---sn-vgqskn7e.googlevideo.com\n"
"r3---sn-vgqsknez.googlevideo.com\n"
"r6---sn-vgqs7ney.googlevideo.com\n"
"r4---sn-vgqskne6.googlevideo.com\n"
"r4---sn-vgqsrnez.googlevideo.com\n"
"r5---sn-vgqskn76.googlevideo.com\n"
"r6---sn-vgqs7ns7.googlevideo.com\n"
"r1---sn-vgqsener.googlevideo.com\n"
"r1---sn-vgqskn7z.googlevideo.com\n"
"r1---sn-vgqsknek.googlevideo.com\n"
"r6---sn-vgqsener.googlevideo.com\n"
"r3---sn-vgqs7nly.googlevideo.com\n"
"r1---sn-vgqsknes.googlevideo.com\n"
"r4---sn-vgqsrnes.googlevideo.com\n"
"r6---sn-vgqskn76.googlevideo.com\n"
"r100---sn-vgqskn76.googlevideo.com\n"
"r101---sn-vgqskn76.googlevideo.com")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.