import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Try upload file : (?<file>.*)\\nUpload File (?<msg>.*)([\\S\\s\\n]*)\\nClosing log at (?<time>.*) on (?<date>.*)";
final String string = "\n"
+ "======================================================================\n"
+ "TGS\n"
+ "======================================================================\n"
+ "Opening log at 1:58:03 PM on 4/29/2016\n\n"
+ "Parameters :\n"
+ "TargetFile:\n"
+ "GeneratedControlFile:False\n"
+ "Path and filename : \n"
+ "Try upload file : \n"
+ "Upload File D:\\Program Files\\X529\\Matrix IT Software PK\\PTS\\Files\\JobLettrers\\AppointLetters_2016_3_25_14_30.csv Complete, status : 226 Transfer complete.\n\n"
+ "Path and filename : D:\\Program Files\\X529\\Matrix IT Software PK\\PTS\\Files\\JobLettrers\\AppointLetters_2016_3_25_14_30.csv\n"
+ "Try upload file : \n"
+ "Upload File D:\\Program Files\\X529\\Matrix IT Software PK\\PTS\\Files\\JobLettrers\\AppointLetters_2016_3_26_14_30.csv Complete, status : 226 Transfer complete.\n\n"
+ "Path and filename : D:\\Program Files\\X529\\Matrix IT Software PK\\PTS\\Files\\JobLettrers\\AppointLetters_2016_3_26_14_30.csv\n"
+ "Try upload file : \n"
+ "Upload File D:\\Program Files\\X529\\Matrix IT Software PK\\PTS\\Files\\JobLettrers\\AppointLetters_2016_3_27_13_30.csv Complete, status : 226 Transfer complete.\n\n"
+ "Path and filename : D:\\Program Files\\X529\\Matrix IT Software PK\\PTS\\Files\\JobLettrers\\BAAppointmentLetters_2016_4_7_13_0.csv\n"
+ "Try upload file : \n"
+ "Upload File D:\\Program Files\\X529\\Matrix IT Software PK\\PTS\\Files\\JobLettrers\\BAAppointmentLetters_2016_4_8_13_0.csv Complete, status : 226 Transfer complete.\n\n"
+ "Path and filename : D:\\Program Files\\X529\\Matrix IT Software PK\\PTS\\Files\\JobLettrers\\BAAppointmentLetters_2016_4_8_13_0.csv\n"
+ "Try upload file : \n"
+ "Upload File D:\\Program Files\\X529\\Matrix IT Software PK\\PTS\\Files\\JobLettrers\\BAAppointmentLetters_2016_4_9_13_0.csv Complete, status : 226 Transfer complete.\n\n"
+ "Path and filename : D:\\Program Files\\X529\\Matrix IT Software PK\\PTS\\Files\\JobLettrers\\BAAppointmentLetters_2016_4_9_13_0.csv\n"
+ "Try upload file : \n"
+ "Upload File D:\\Program Files\\X529\\Matrix IT Software PK\\PTS\\Files\\JobLettrers\\BAAppointmentLetters_2016_4_9_13_0.csv Complete, status : 226 Transfer complete.\n\n"
+ "Closing log at 2:00:56 PM on 4/29/2016\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}