$re = '/^(?:.*?[.,;])?\s*(?:(?:for|by)\s*me\s*)?(\w.*?)(?=\s*other\s*text)/m';
$str = 'dfdfdfd fdfdfdf other text. hghhg
Hello how are you?, dfdfdfd fdfdfdf other text.hghhg
for me a word other text
A semicolon first; then some words before other text
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);