package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*?($|\$[sc]\d)`)
var str = ` Есть текст и много строк
В тексте встречаются $s1 $s2 $s3 $s4 $c1 $c2 $c4
В каждой строке есть хоть 1 такой текст, могут быть и 2 и 3 в 1 строке, но без дублей.
Найти я смог их так (\$s\d)|(\$c\d) и удалить могу их всех, но как удалить все кроме них не понял.
Заранее спасибо за ответ! `
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}