package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\d{5}$`)
var str = `33072`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}