# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[A-ZÄäÖöÜüß][A-ZÄäÖöÜüß.\s-]*?\s*\d+(?:[/-]\d+)?(?:[A-Z](?:-[A-Z])?)?\b"
test_str = (".74\n"
"Berliner Str. 74\n"
"Hindenburgdamm 27, Hygiene-Institut\n"
"Peschkestr. 5a/Holsteinische Str. 44\n"
"Lankwitzer Str. 13-17a\n"
"Fidicinstr. 15A\n"
"Johanna-Stegen-Strasse 14a-d\n"
"Friedrichshaller Str. 7\n"
"Haudegen Weg 15/17\n"
"Südwestkorso 9")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.