re = /<td class="lineColumn">(.*)<\/td>(.*)<td class="stationColumn">(.*)<span(.*)<td class="inMinColumn">(.*)<\/td>/
str = '
<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">
<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1">
<meta name="viewport" content="width=340px">
<title>MVG-Live: Westkreuz Bf.</title>
<link type="text/css" rel=\'stylesheet\' href=\'css/size30/mvg/mvglive-mobile.css\' media=\'all\'>
</head>
<body>
<div class="departureTable header logo">
<div class="logoLeft">
<img class="logoImgLeft" src="images/size30/grafik/mvg/mobile-logo-left.jpg" alt="MVG live">
</div>
<div class="logoRight">
<img class="logoImgRight" src="images/size30/grafik/mvg/mobile-logo-right.jpg" alt="MVG live">
</div>
</div>
<table class="departureTable departureView">
<tr>
<td colspan="2" class="headerStationColumn">Westkreuz Bf.</td>
<td colspan="2" class="serverTimeColumn">21:33</td>
</tr>
<tr>
<td colspan="4" class="sBahnHeader">S-Bahn München (Daten DB Regio AG)</td>
</tr>
<tr class="rowOdd">
<td class="lineColumn">S6</td>
<td class="stationColumn">
Ebersberg(Oberbay)
<span class="spacer"> </span>
</td>
<td class="inMinColumn">1</td>
</tr>
<tr class="rowEven">
<td class="lineColumn">S8</td>
<td class="stationColumn">
Herrsching
<span class="spacer"> </span>
</td>
<td class="inMinColumn">5</td>
</tr>
<tr class="rowOdd">
<td class="lineColumn">S8</td>
<td class="stationColumn">
München Flughafen Terminal
<span class="spacer"> </span>
</td>
<td class="inMinColumn">6</td>
</tr>
<tr class="rowEven">
<td class="lineColumn">S6</td>
<td class="stationColumn">
Starnberg
<span class="spacer"> </span>
</td>
<td class="inMinColumn">11</td>
</tr>
<tr class="rowOdd">
<td class="lineColumn">S6</td>
<td class="stationColumn">
Ebersberg(Oberbay)
<span class="spacer"> </span>
</td>
<td class="inMinColumn">21</td>
</tr>
<tr class="rowEven">
<td class="lineColumn">S8</td>
<td class="stationColumn">
Weßling(Oberbay)
<span class="spacer"> </span>
</td>
<td class="inMinColumn">25</td>
</tr>
<tr class="rowOdd">
<td class="lineColumn">S8</td>
<td class="stationColumn">
München Flughafen Terminal
<span class="spacer"> </span>
</td>
<td class="inMinColumn">26</td>
</tr>
<tr class="rowEven">
<td class="lineColumn">S6</td>
<td class="stationColumn">
Tutzing
<span class="spacer"> </span>
</td>
<td class="inMinColumn">31</td>
</tr>
<tr class="rowOdd">
<td class="lineColumn">S6</td>
<td class="stationColumn">
Grafing Bahnhof
<span class="spacer"> </span>
</td>
<td class="inMinColumn">41</td>
</tr>
<tr class="rowEven">
<td class="lineColumn">S8</td>
<td class="stationColumn">
Herrsching
<span class="spacer"> </span>
</td>
<td class="inMinColumn">45</td>
</tr>
<tr class="rowOdd">
<td class="lineColumn">S8</td>
<td class="stationColumn">
München Flughafen Terminal
<span class="spacer"> </span>
</td>
<td class="inMinColumn">46</td>
</tr>
<tr class="rowEven">
<td class="lineColumn">S6</td>
<td class="stationColumn">
Tutzing
<span class="spacer"> </span>
</td>
<td class="inMinColumn">51</td>
</tr>
<tr class="rowOdd">
<td class="lineColumn">S6</td>
<td class="stationColumn">
Ebersberg(Oberbay)
<span class="spacer"> </span>
</td>
<td class="inMinColumn">61</td>
</tr>
<tr class="rowEven">
<td class="lineColumn">S8</td>
<td class="stationColumn">
Weßling(Oberbay)
<span class="spacer"> </span>
</td>
<td class="inMinColumn">65</td>
</tr>
<tr class="rowOdd">
<td class="lineColumn">S8</td>
<td class="stationColumn">
München Flughafen Terminal
<span class="spacer"> </span>
</td>
<td class="inMinColumn">66</td>
</tr>
<tr class="rowEven">
<td class="lineColumn">S6</td>
<td class="stationColumn">
Tutzing
<span class="spacer"> </span>
</td>
<td class="inMinColumn">71</td>
</tr>
<tr class="rowOdd">
<td class="lineColumn">S6</td>
<td class="stationColumn">
Ebersberg(Oberbay)
<span class="spacer"> </span>
</td>
<td class="inMinColumn">81</td>
</tr>
<tr class="rowEven">
<td class="lineColumn">S8</td>
<td class="stationColumn">
Herrsching
<span class="spacer"> </span>
</td>
<td class="inMinColumn">85</td>
</tr>
<tr class="rowOdd">
<td class="lineColumn">S8</td>
<td class="stationColumn">
München Flughafen Terminal
<span class="spacer"> </span>
</td>
<td class="inMinColumn">86</td>
</tr>
<tr class="rowEven">
<td class="lineColumn">S6</td>
<td class="stationColumn">
Tutzing
<span class="spacer"> </span>
</td>
<td class="inMinColumn">91</td>
</tr>
<tr>
<td colspan="4" class="reloadLink">
<a href="/ims/dfiStaticAnzeige.svc?haltestelle=Westkreuz Bf.&ubahn=&bus=&tram=&sbahn=checked">
Fahrten aktualisieren
</a>
</td>
</tr>
</table>
<table class="departureTable footerTable">
<tr>
<td class="footer">
<a href="http://www.mvg-mobil.de/impressum.htm" target="_blank">Impressum</a>
</td>
</tr>
</table>
</body>
</html>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end