using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?P<clb_timestamp>[^\s]+)\s*(?P<clb_elb>[^\s]+)\s*(?P<clb_client_addr>[^:]+):\s*(?P<clb_client_port>[^\s]+)\s*(?P<clb_target_addr>[^:]+):\s*(?P<clb_target_port>[^\s]+)\s*(?P<clb_request_processing_time>[^\s]+)\s*(?P<clb_backend_processing_time>[^\s]+)\s*(?P<clb_response_processing_time>[^\s]+)\s*(?P<clb_elb_status_code>[^\s]+)\s*(?P<clb_backend_status_code>[^\s]+)\s*(?P<clb_received_bytes>[^\s]+)\s*(?P<clb_sent_bytes>[^\s]+)\s*""(?P<clb_request>[^\""]+)""\s*(?P<clb_user_agent>[^\s]+)\s*(?P<clb_ssl_cipher>[^\s]+)\s*(?P<clb_ssl_protocol>[^\s]+)";
string input = @"2015-05-13T23:39:43.945958Z my-loadbalancer 192.168.131.39:2817 10.0.0.1:80 0.000086 0.001048 0.001337 200 200 0 57 ""GET https://www.example.com:443/ HTTP/1.1"" ""curl/7.38.0"" DHE-RSA-AES128-SHA TLSv1.2
2015-05-13T23:39:43.945958Z my-loadbalancer 192.168.131.39:2817 10.0.0.1:80 0.001069 0.000028 0.000041 - - 82 305 ""- - - "" ""-"" - -
2015-05-13T23:39:43.945958Z my-loadbalancer 192.168.131.39:2817 10.0.0.1:80 0.001065 0.000015 0.000023 - - 57 502 ""- - - "" ""-"" ECDHE-ECDSA-AES128-GCM-SHA256 TLSv1.2";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}