package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:A[B-H]|B[C-H]|B[C-H]|D[E-H]|E[FGH]|F[GH]|GH)(?:D[E-M]|E[F-M]|F[G-M]|G[H-M]|H[I-M]|I[J-M]|J[KLM]|LM)`)
var str = `AHDM
BCEF
FAIL
CBFE`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}