$re = '/([A-z]+)(=\x22)([A-z]+)(\x22)/m';
$str = '<p attributeA="foo" attributeB="bar" attributeC="baz" attributeD="qux"></p>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);