package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`abc\*`)
var str = `abc*`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}