package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)({\$\w+})`)
var str = `{$foo}
{$foo_090_}
{$foo_@#$%_5678}
{$foo_@#$%_{+[]:}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}