# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?s)^.*?\"longitude[^\[]*?\"activity[^\[]*\[[^\]]*?timestampMs\"[^\"\]]*\"(\d+)\"[^\]]*WALKING[^\]]*?confidence\"\s*:\s*(\b\d{1,3}\b)[^\]]*?\].*$"
test_str = (" }, {\n"
" \"timestampMs\" : \"1515564666086\", ◁― Don't need this but it won't hurt\n"
" \"latitudeE7\" : -6857630899, \n"
" \"longitudeE7\" : -1779694452999,\n"
" \"activity\" : [ {\n"
" \"timestampMs\" : \"1515564665992\", ◁― EXAMPLE: I want only this, and...\n"
" \"activity\" : [ {\n"
" \"type\" : \"STILL\",\n"
" \"confidence\" : 65\n"
" }, {\n"
" \"type\" : \"TILTING\", ↓\n"
" \"confidence\" : 4\n"
" }, {\n"
" \"type\" : \"IN_RAIL_VEHICLE\",\n"
" \"confidence\" : 20\n"
" }, {\n"
" \"type\" : \"IN_ROAD_VEHICLE\",\n"
" \"confidence\" : 5\n"
" }, {\n"
" \"type\" : \"ON_FOOT\", ↓\n"
" \"confidence\" : 3\n"
" }, {\n"
" \"type\" : \"UNKNOWN\",\n"
" \"confidence\" : 3\n"
" }, {\n"
" \"type\" : \"WALKING\", ◁― ...AND, I also want this.\n"
" \"confidence\" : 3\n"
" } ]\n"
" } ]\n"
" }, {\n"
" \"timestampMs\" : \"1515564662594\", ◁― Don't need this but it won't hurt\n"
" \"latitudeE7\" : -6857630899, \n"
" \"longitudeE7\" : -1779694452999,\n"
" \"altitude\" : 42\n"
" }, {")
subst = "\\1 \\2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.