$re = '/(.*) \((.+)\)$/m';
$str = 'Am weißen Strand von Sourabaya ( NH 22 429 ) ( NH 22 429 )
Am weißen Strand von Sourabaya (NH 22 429)
Am weißen Strand von Sourabaya (NH 22 429) (NH 22 429)
Test mit ( Capitol F 2486 )
Ein ( Klammertest ) mit anderem Inhalt ( RCA 20-4459 )';
$subst = "$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;