$re = '/^090\d{5}$/m';
$str = '09032711
090327112
0903271122';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);