re = /Filename\((?<IBAN>[^\)]+)/m
str = '2023-01-04 15:08:09.001175 DEBUG [0xce4] VoiceRecorderUpdateTask.cpp[28] VoiceRecorderUpdateTask::runTask: MSG_VOICERECORDING_NOTIFY:SRC_NOTIFY_NO_PACKETS : Filename(4281-1672873674000-4125-SEP12345678-98962688)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end