import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<date>\\d{2}\\.\\d{2}\\.\\d{4})\\s(?<time>\\d{2}:\\d{2}:\\d{2}\\.\\d{3})\\s{2}(?<msg>.+?(?=\\s\\d))\\s(?<id>.{4})\\s(?<name>.+?(?=$|\\d{2}\\.))(?<comment>.*$)";
final String string = "04.08.2024 06:41:14.775 Получено время 2447 Название устройства №2 04.08.2024 6:41:15 - синхронизация не требуется\n"
+ "04.08.2024 06:43:14.786 Получено время 22B3 Название устройства №3 04.08.2024 6:43:16 - время получения ответа превышает допуск\n"
+ "04.08.2024 11:47:01.967 Истекли попытки отправить запрос 234C Название устройства №4\n"
+ "05.08.2024 14:03:55.149 Получено время 2356 Название устройства №1 05.08.2024 14:03:57 - время получения ответа превышает допуск\n"
+ "05.08.2024 14:03:56.796 Получено время 2356 Название устройства №1 05.08.2024 14:03:58 - требуется синхронизация\n"
+ "05.08.2024 14:03:58.920 Установлена коррекция времени 2356 Название устройства №1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}