package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:[^'"]|^)(https?:\/\/)`)
var str = `http:// https:// xhttps:// "https:// 'https://`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}