use strict;
my $str = '__Required Date__40X0343 1.00__C734X77G 2.00__Net Order:__Sales Tax:__Freight:__Order Total:__0.00 __0.00 __5,328.50 __5,328.50 __or by fax
';
my $regex = qr/(?x)Required\sDate
(?<Line>__
(?<PartNo1>[a-zA-Z0-9-]*)\s
(?<OrderQuantity1>[0-9.]+)
__
(?<PartNo2>[a-zA-Z0-9-]*)\s
(?<OrderQuantity2>[0-9.]+)
)*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}