$re = '/^(?!.*\s)(?=.{8,256}$)(?=.*[a-z])(?=.*[A-Z])(?=.*[0-9])(?=.*[~!@#$%^&*()\-=_+[\]{}|;:,.\/<>?].*[~!@#$%^&*()\-=_+[\]{}|;:,.\/<>?].*).*$/m';
$str = 'Abh@inav12$';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);