$re = '/^>>\w.*(?<!<)<{2}\d.*!\d.*/m';
$str = '>>item 1<<4$!4
>>item 2<<<123$!12
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);