const regex = /^\s{0,4}N\s{0,4}O\s{0,4}(?:[0-9a-zA-Z]\s{0,4}){13}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\s{0,4}N\\s{0,4}O\\s{0,4}(?:[0-9a-zA-Z]\\s{0,4}){13}$', 'gm')
const str = `NO1 234 5678 9012 3`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}