use strict;
my $str = '/scratch/downloads/52aa233b-5db4-2298-5e1b-f510b2cd149f/configBundle-ESXi-X10SRH-CF.tgz';
my $regex = qr/(\/scratch\/downloads\/[[:xdigit:]]{8}-[[:xdigit:]]{4}-[[:xdigit:]]{4}-[[:xdigit:]]{4}-[[:xdigit:]]{12}\/)(configBundle-.+?)(.tgz)$/mp;
my $subst = '$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";