re = /(?<!\S)[A-Z][a-z]*(?!\S)|([A-Z][a-z]*)/m
str = 'AppleOrange
AppleOrangePear
Pomegranate Yellow Banana'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end