package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d+:\d+(?::\d+)?|(:\w+)`)
var str = `2018-05-21T00:00:00+02:00
00:00:00
00:00
:light at 07:15:0000`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}