using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<span(?=\s)(?=(?:[^>""']|""[^""]*""|'[^']*')*?\sstyle\s*=\s*(?:(['""])(?:(?!\1)[\S\s])*?font-weight:700(?:(?!\1)[\S\s])*\1))\s+(?:""[\S\s]*?""|'[\S\s]*?'|[^>]*?)+>([\S\s]*?)<\/span\s*>";
string substitution = @"<strong>$2</strong>";
string input = @"<p><span style=""color:#2c2c2c;font-weight:700;text-decoration:none;vertical-align:baseline;font-size:10.5pt;font-family:"Arial";font-style:normal"">Strong content</span></p><ul><li><span style=""color:#2c2c2c;font-weight:400;text-decoration:none;vertical-align:baseline;font-size:10.5pt;font-family:"Arial";font-style:normal"">list item</span></li><li><span style=""color:#2c2c2c;font-weight:400;text-decoration:none;vertical-align:baseline;font-size:10.5pt;font-family:"Arial";font-style:normal"">list item</span></li><li><span style=""color:#2c2c2c;font-weight:400;text-decoration:none;vertical-align:baseline;font-size:10.5pt;font-family:"Arial";font-style:normal"">list item</span></li><li><span style=""color:#2c2c2c;font-weight:400;text-decoration:none;vertical-align:baseline;font-size:10.5pt;font-family:"Arial";font-style:normal"">list item</span></li><li><span style=""color:#2c2c2c;font-weight:400;text-decoration:none;vertical-align:baseline;font-size:10.5pt;font-family:"Arial";font-style:normal"">list item</span></li><li><span style=""color:#2c2c2c;font-weight:400;text-decoration:none;vertical-align:baseline;font-size:10.5pt;font-family:"Arial";font-style:normal"">list item</span></li></ul><p><span style=""color:#2c2c2c;font-weight:400;text-decoration:none;vertical-align:baseline;font-size:10.5pt;font-family:"Arial";font-style:normal"">Content text</span></p><p><span style=""color:#2c2c2c;font-weight:400;text-decoration:none;vertical-align:baseline;font-size:10.5pt;font-family:"Arial";font-style:normal"">Content text</span></p><p><span style=""color:#2c2c2c;font-weight:400;text-decoration:none;vertical-align:baseline;font-size:10.5pt;font-family:"Arial";font-style:normal"">Content text</span></p><p><span style=""font-size:10.5pt;color:#2c2c2c;font-weight:700"">Should be bold</span><span style=""color:#2c2c2c;font-weight:400;text-decoration:none;vertical-align:baseline;font-size:10.5pt;font-family:"Arial";font-style:normal"">: regular text</span></p><p><span style=""font-size:10.5pt;color:#2c2c2c;font-weight:700"">Should be bold</span><span style=""color:#2c2c2c;font-weight:400;text-decoration:none;vertical-align:baseline;font-size:10.5pt;font-family:"Arial";font-style:normal"">: regular text </span></p><p><span style=""font-size:10.5pt;color:#2c2c2c;font-weight:700"">Should be bold</span><span style=""color:#2c2c2c;font-weight:400;text-decoration:none;vertical-align:baseline;font-size:10.5pt;font-family:"Arial";font-style:normal"">: regular text</span></p>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}