re = /^(.*?([^s](?=.*?h.*?m.*?p)|s).*?([^h](?=.*?m.*?p)|h).*?([^m](?=.*?p)|m).*?.)/m
str = 'shampoo
shanpoo
sharpoo
thampoo
tharpoo
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end