$re = '/(&?page=1\&) |(&?page=*01$)/';
$str = 'http://cms/?page=1&message=2&page=3&page=01';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);