import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\w[\\w.]+\\w)$";
final String string = "brew.pixels\n"
+ "brew.pixels\n"
+ "dfg21.dfgd\n\n\n\n"
+ "brew.pixels.\n"
+ ".brew.pixels";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}