$re = '/^(?!07|\+?467).*/m';
$str = '07
+467
467
08
222';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);