$re = '/^[a-zA-Z0-9]{3,4}$/m';
$str = 'print(username)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);