package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(456)#\b`)
var str = `123456#b xyz`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}