#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?ms)pid.*?req"
Local $sString = "Format which I need:" & @CRLF & _
"" & @CRLF & _
"2019-11-10 15:22:32.662 +0300 (Default,mydzit.gov.sa\kalsolai,4C8EC4A70F3149988B93370B16CADBEE-0:0,XcgBCNSpBpjM51ezrQYXrQAAAgE) catalina-exec-150 : INFO wgsessionId=rd9xUhIUR92tuPbGQkZrNQ com.tableausoftware.domain.session.SessionService - Non-guest user session found." & @CRLF & _
"" & @CRLF & _
"AND:" & @CRLF & _
"" & @CRLF & _
"2019-11-10 15:22:40.816 +0300 (Default,mydzit.gov.sa\kalsolai,F853E8F10C2742CBB071A090C3047519-0:0,XcgBENSpBpjM51ezrQYXvwAAAZE) catalina-exec-151 : INFO wgsessionId=rd9xUhIUR92tuPbGQkZrNQ com.tableausoftware.model.vizql.util.WithSessionAspect - Command not allowed on a shared session F853E8F10C2742CBB071A090C3047519. Cloning to a private session and retrying." & @CRLF & _
"" & @CRLF & _
"Format which no need:" & @CRLF & _
"" & @CRLF & _
"first form:" & @CRLF & _
"{ [-]" & @CRLF & _
"k: msg" & @CRLF & _
"pid: 37552" & @CRLF & _
"req: -" & @CRLF & _
"sess: -" & @CRLF & _
"sev: info" & @CRLF & _
"site: -" & @CRLF & _
"tid: 4958" & @CRLF & _
"ts: 2019-11-06T17:06:06.305" & @CRLF & _
"user: -" & @CRLF & _
"v: Resource Manager: Memory info: 73,793,536 bytes (current process);52,410,015,744 bytes (Tableau total); 49,979,158,528 bytes (total of all processes); 30 (info count)" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"Second Form:" & @CRLF & _
"{"ts":"2019-11-06T17:06:06.305","pid":37552,"tid":"4958","sev":"info","req":"-","sess":"-","site":"-","user":"-","k":"msg","v":"Resource Manager: Memory info: 73,793,536 bytes (current process);52,410,015,744 bytes (Tableau total); 49,979,158,528 bytes (total of all processes); 30 (info count)"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")