$re = '/^(.(?<!act))*?true/m';
$str = 'true
trueact
acttrue
act true
act really true';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);