$re = '/(?:\s|^)(#(?![\da-fA-F]{6}\b)[^<\s]+)/';
$str = ' #tags #af93bd #hello';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);