$re = '/baz=([^=]*)(?=&|$)/';
$str = 'foo=bar&baz=qux&norf&corge=grault
baz=sdasd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);