$re = '/^[\w]([^@\s,;]+)@(?:([\w-]+\.)+edu|mypost\.com)$/m';
$str = 'john@learn.edu
john@learn.sdasd.edu
john@mypost.com
john@gmail.com
john@dblist.org';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);