import re
regex = re.compile(r"\+7\s\(\d{3,4}\)\s\d{2,3}\-\d{2}\-\d{3}", flags=re.MULTILINE)
test_str = ("+7 (3452) 10-10-105\n"
"+7 (343) 100-10-105")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")