$re = '/Are you interested in a holiday in [^,]+,\s*then contact [^@]+@[\S]+/mi';
$str = 'Hello there. Are you interested in a holiday in New York, then contact nyc@mydomain.com. Let us help you.
Hey mr! Are you interested in a holiday in LA, then contact la@mydomain.com. We got you!
Welcome to our humbo home. Are you interested in a holiday in France, then contact france@mydomain.com. See you soon!
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;