#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "import(?:[\s*]([\w*{}\n\r\t, ]+)[\s*]from)?[\s*](?:["'](.*[\w]+)["'])?"
Local $sString = "import {" & @CRLF & _
" Component" & @CRLF & _
"} from '@angular2/core';" & @CRLF & _
"import defaultMember from "$module-name";" & @CRLF & _
"import * as name from "module-name ";" & @CRLF & _
"import { member } from " module-name";" & @CRLF & _
"import { member as alias } from "module-name";" & @CRLF & _
"import { member1 , member2 } from "module-name";" & @CRLF & _
"import { member1 , member2 as alias2 , member3 as alias3 } from "module-name";" & @CRLF & _
"import defaultMember, { member, member } from "module-name";" & @CRLF & _
"import defaultMember, * as name from "module-name";" & @CRLF & _
"import "module-name";" & @CRLF & _
"import {" & @CRLF & _
" PlaneBufferGeometry," & @CRLF & _
" OctahedronGeometry," & @CRLF & _
" TorusBufferGeometry" & @CRLF & _
"} from '../geometries/Geometries.js'" & @CRLF & _
"" & @CRLF & _
"<MenuItem value="^$" primaryText="Não exibir importados" />" & @CRLF & _
"<MenuItem value="\\w+" primaryText="Exibir importados" />" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")